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Introduction

Welcome to the Keysight VEE family! Keysight Visual Engineering 
Environment (VEE) is a powerful visual language environment that 
dramatically reduces your development time. To get you started 
quickly on Keysight VEE, we have prepared this guide to show you 
how to install and use your new software. This guide also contains 
two tutorials that show you how to communicate with an instrument 
via the USB interface, and how to generate and display a waveform 
from a virtual source.

Installing Keysight IO Libraries

The Keysight IO Libraries Suite software is included when you 
purchase Keysight VEE. This software enables you to communicate 
with instruments via serial, USB, GPIB, or LAN interfaces. 

You are required to install the Keysight IO Libraries Suite 
16.3.16603.3 before installing Keysight VEE if you need to 
communicate with instruments using Keysight VEE. However, you can 
choose not to install the Keysight IO Libraries Suite if you do not use 
instruments. 

Follow these simple installation steps:

1 Insert Keysight IO Libraries Suite CD into the CD- ROM drive.

2 The InstallShield Wizard will guide you through the installation 
process. Click Next to accept the default settings and complete the 
installation.
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3 The Keysight Connection Expert Welcome Screen window will 
appear. This application configures the instruments that are 
connected to your PC. You may close this window before 
proceeding to the next step.
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Installing Keysight VEE Pro

1 Insert the Keysight VEE Installation CD- ROM and click Install 
Keysight VEE Pro 9.32. The InstallShield Wizard will guide you through 
the installation process. 

2 The InstallShield Wizard will check if Keysight IO Libraries Suite 
16.3.16603.3 is installed. If it is not, the following message box will 
appear.

Please note that Keysight IO Libraries Suite 16.3.16603.3 is a 
prerequisite if you communicate with instruments using Keysight 
VEE. So, please install Keysight IO Libraries Suite 16.3.16603.3 or 
higher after finishing this installation.

3 Click OK, the InstallShield Wizard will check if Microsoft .NET 
Framework 3.5 SP1 is installed.
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4 If Microsoft .NET Framework 3.5 SP1 is not installed, following 
Question dialog box will appear to ask you to install it. Click Yes to 
install the Microsoft .NET Framework 3.5 SP1 immediately. After 
the installation, the Keysight VEE installation will continue 
automatically. Clicking No will abort the Keysight VEE installation.

If Microsoft .NET Framework 3.5 SP1 is installed, the InstallShield 
Wizard will guide you to the next step directly to install your 
Keysight VEE selection in Step 1.

5 Click Next, when the following dialog box appears.

6 Accept the license agreement when the License Agreement dialog 
box appears, then click Next.
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7 Type your name, company name, and product key when the 
Customer Information dialog box appears, then click Next. The 
product key is contained in the KeysightVEE Pro Product Key 
Certificate. 
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8 Click Next to accept the default settings when the following dialog 
box appears. 

9 Select Typical Setup when the Setup Type dialog box appears, then 
click Next to complete the installation.
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Launching Keysight VEE Pro

Go to All Programs > Keysight VEE Pro 9.3 > VEE Pro 9.3 to launch Keysight 
VEE Pro.

You can access the demos, MATLAB examples as well as sample 
programs via the Keysight VEE Pro welcome window. You may close 
the window after exploring it.

You can also open sample programs from the menu bar. To open a 
sample program, go to File > Open Example ...or Help > Open Example....

Output 
Window

Workspace

Program 
Explorer

Properties
Window

Toolbar

Status Bar

Menu Bar

Welcome 
Window
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Instrument Communication Tutorial

In this tutorial, we will connect to an instrument via the USB 
interface. Ensure that the Keysight IO Libraries Suite 16.3.16603.3 is 
installed before proceeding. 

If you do not have a USB instrument, the tutorial for a GPIB 
instrument is similar from Step 3 onwards. 

1 Connect to an instrument via any USB port on your PC. Then, turn 
on the instrument. The Found New Hardware Wizard dialog box 
will appear. Just step through the wizard by clicking Next.

2 Launch Keysight VEE Pro, if you have not. Click the Instrument 
Manager button  on the toolbar. 

3 The Instrument Manager tool window will appear. Click the Find 

Instruments button  to automatically detect all instruments 
connected to your PC.

4 Click OK if the Identify Instrument pop- up dialog box appears. This 
automatically identifies the instrument on the USB interface. In 
this example, the Keysight 34450A 5½ Digit Multimeter is present.
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5 Right click newInstrument in the Instrument List panel. Then, 
choose Create Direct I/O Object to place a Direct I/O object for the 
selected newinstrument on the workspace. This object allows you to 
send/receive commands to/from your instrument.

6 Double- click the Direct I/O object blue transaction bar to add a 
transaction to the Direct I/O object.

7 Type "*IDN?" (include the quotation marks) in the I/O 
Transaction dialog box as shown below. A list of available SCPI 
commands may appear while you are typing. You can choose one 
command as desired instead of typing the whole command. Click 
OK to proceed.
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*IDN? is one of standard commands for programmable instruments 
(SCPI) command that queries the instrument for its identification 
string.

8 After sending the "*IDN?" query to the instrument, you need to 
read back its response. Double- click the text box of the 
newInstrument object to add a new transaction. This time, select 
the transaction to READ a STRING FORMAT text to an output terminal 
named x. The output terminal x will be automatically created when 
you click OK.
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9 Select Display > AlphaNumeric and place an AlphaNumeric object on 
the workspace to the right of the Direct I/O object.

10 You will now connect the Direct I/O object to the AlphaNumeric 
object. Place the mouse cursor beside the Direct I/O output 
terminal and a square icon will appear. Left- click and drag a line 
to the input terminal of the AlphaNumeric object. Left- click again 
to complete the connection.

11 Run the program by clicking the Run button on the toolbar.

12 The AlphaNumeric object will display the identification string 
output by the instrument as shown below.

13 To save your VEE code, select File > Save As and name the file as 
Tutorial 1.vee.
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Virtual Source Tutorial

In this tutorial, you will generate and display a waveform from a 
virtual source. No instrument is needed.

1 If you have an existing program in your Keysight VEE Pro 
workspace, select File > New. Then, select Device > Virtual Source > 
Function Generator and place a function generator object on the 
workspace.

2 By default, the function generator will generate a virtual cosine 
waveform at a frequency of 200 Hz, and an amplitude of 1. 
Keysight VEE Pro 9.32 Quick Start Guide 13



3 Select Display > XY Trace and place an XY Trace object to the right of 
the function generator. 

4 Connect the function generator output terminal to the input 
terminal of the XY trace. Place the mouse cursor beside the 
function generator output terminal and a square icon will appear. 
Left- click and drag a line to the input terminal of the XY Trace 
object. Left- click again to complete the connection.
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5 Click the Run button  on the toolbar and you can see the 
cosine waveform displayed on the XY Trace object. 

6 Select Display > Spectrum (Freq) > Magnitude Spectrum and place a 
Magnitude Spectrum object on the workspace below the XY Trace 
object.
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7 Connect a second line from the output of the function generator to 
the input of the Magnitude Spectrum object using the same 
left- click and drag method as described in Step 4.

8 Click the Run button  and observe the magnitude spectrum 
display. As the waveform is a 200 Hz cosine, the magnitude 
spectrum displayed will be a vertical line at the frequency of 
200 Hz.
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9 Change the waveform function on the virtual function generator to 
a square waveform.

10 Click the Run button  and observe the difference. Keysight VEE 
gives you the flexibility to analyze your signal source in multiple 
graph displays simultaneously. 
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11 To save your VEE code, select File > Save As and name the file as 
Tutorial 2.vee.
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Keysight VEE 9.32 New Features

Windows 8 Supportability

Keysight VEE 9.32 supports Windows 8 (Professional and Enterprise 
with 32- bit and 64- bit supportability). Note that the 64- bit support 
has a 32- bit application running on WOW64 (Windows- on- Windows 
64- bit) emulator.

Microsoft Office Excel 2013 Supportability

Keysight VEE 9.32 (and above) existing built- in Excel menu supports 
Microsoft Office Excel 2013. However, new features in Microsoft Office 
Excel 2013 are not supported.

NOTE Keysight also provides Keysight VEE Student and Keysight Education versions for 
academic users.
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Keysight Connectivity Products

Keysight provides a complete range of high performance and highly 
reliable products to connect from your PC to your instruments. These 
include LAN/GPIB/USB gateway, GPIB cable, and PCI GPIB, PCIe 
GPIB, and USB/GPIB interfaces. For more information on Keysight 
connectivity products, visit www.keysight.com/find/gpib.

E5810B LAN/GPIB/USB Gateway 10833X GPIB Cable

82350B PCI GPIB Interface

82357B USB/GPIB Interface

82351A PCIe GPIB Interface
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Keysight Support, Services, and Assistance

With Keysight VEE Pro, you have access to the Keysight worldwide 
resources for start- up assistance, training classes, and update 
services. As part of the purchase of any Keysight VEE product you 
are entitled to receive technical support free of charge. There is no 
need to register. 

Additional consulting services are available from Keysight. There are 
currently over 30 companies available in North America, Europe, 
Middle East and Asia to help you develop your Keysight VEE solution.

Sign up for the Keysight VEE forum at 
http://www.keysight.com/find/veeforum, and get help on using 
Keysight VEE from experts around the world.

Sign up for Keysight VEE e- learning courses (LearnVEE) at 
http://www.keysight.com/find/learnvee.

For an interactive help, you may also view Keysight VEE multimedia 
demos at http://www.keysight.com/find/veedemos.
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Appendix

Keysight VEE Pro Help is now available in other languages. To use 
online help file in other languages, please 

1 Download localized online help from www.keysight.com/find/vee.

2 Save downloaded files into the installation directory of Keysight 
VEE. Generally, it is C:\Program Files\Keysight\VEE Pro 9.3 (32- bit 
operating system) or C:\Program Files (x86)\Keysight\VEE Pro 9.3 
(64- bit operating system). Please do not change the name of the 
downloaded online help files.

3 Open Keysight VEE software.

4 Open the Default Preferences (File > Default Preferences). Choose the 
help file language as you need under the Help tab.

5 Click OK to close the Default Preferences dialog box.
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Contact us
To obtain service, warranty, or technical 
assistance, contact us at the following 
phone or fax numbers:
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(tel) 800 829 4444 (fax) 800 829 4433
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(tel) 877 894 4414 (fax) 800 746 4866
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(tel) 800 810 0189 (fax) 800 820 2816

Europe:

(tel) 31 20 547 2111
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(tel) 0120 (421) 345 (fax) 0120 (421) 678

Korea:

(tel) (080) 769 0800 (fax) (080) 769 0900

Latin America:

(tel) (305) 269 7500

Taiwan:

(tel) 0800 047 866 (fax) 0800 286 331

Other Asia Pacific Countries:

(tel) (65) 6375 8100 (fax) (65) 6755 0042

Or visit Keysight World Wide Web at:
www.keysight.com/find/assist
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